Wednesday, March 30, 2011

GNUmed 0.9.0 released

Hello all,

I am glad to be able to announce the immediate availability
of the GNUmed 0.9.0 Feature Release.


Downloads available from:

http://www.gnumed.de/downloads/client/0.9/
http://www.gnumed.de/downloads/server/v15/


Client installation:

Easily installable packages for your platform of choice
will be available shortly.

Meanwhile you can run the client from a downloaded tarball
or use the net based client installer:

http://www.gnumed.de/downloads/client/gm-install_client_locally.sh

which you need to download, make executable, and run.

More information available here:

http://wiki.gnumed.de/bin/view/Gnumed/InstallerGuideHomeShort


Database installation / upgrade:

Note that this release, as usual, DOES require a database
upgrade from v14 to v15 if you already have a database and
wish to retain the patient data you documented therein. For
uprading you can use the script provided in the tarball:

.../server/bootstrap/upgrade-db.sh 14 15

Alternatively, you can use the network upgrader:

http://www.gnumed.de/downloads/server/net_upgrade-gnumed_server.sh

which you need to download, make executable and run.

If you wish to install a fresh database (without upgrading
an existing one) you can use the install script:

.../server/bootstrap/bootstrap-latest.sh

or, again, the network based installer:

http://www.gnumed.de/downloads/server/net_install-gnumed_server.sh

Note that both ways WILL DELETE existing databases !

More information on installation or upgrading is found here:

http://wiki.gnumed.de/bin/view/Gnumed/ServerInstall
http://wiki.gnumed.de/bin/view/Gnumed/ServerUpgrade


Changelog:

0.9.0

NEW: use much enhanced, file-based FreeDiams API
NEW: support primary provider on patients along with configurable fallback
NEW: support array of contextual FKs per inbox message
NEW: support dicomscope as DICOM viewer
NEW: support summary field on health issues and episodes
NEW: translate database strings from within client and contribute translations
NEW: simplistic coding systems browser
NEW: cloning of workplaces
NEW: hook "post_person_creation"
NEW: placeholder: "emr_journal::soap//%(narrative)s//255//tex::9999"
NEW: LaTeX template: chronological EMR journal
NEW: placeholder: "free_text::tex//::9999"
NEW: LaTeX template: generic free-text medical statement (English and German)
NEW: full manual management of substances/drug components/branded drugs
NEW: implement our own date picker
NEW: implement searchable tags with image/name/comment on patients
NEW: Greek translation
NEW: log failed gm-dbo database access in database during restricted procedures
NEW: change gm-dbo password from client
NEW: implement leaving a message for oneself/other providers
NEW: Gulich Score on GABHS in sore throat
NEW: implement generic method for downloading data packs
NEW: placeholder: "soap_for_encounters::soap//::9999"
NEW: make client font configurable

IMPROVED: link test results directly to requests for them
IMPROVED: much better EMR tree root node tooltip
IMPROVED: improved adding of vaccinations
IMPROVED: now listing episodes/health issues at time of creation in EMR journal
IMPROVED: Boesner score now has internationally usable name: "Marburg CHD score"
IMPROVED: much better integration of visual progress notes
IMPROVED: procedures now support a duration and an "ongoing" state
IMPROVED: adjust to modified API of MMI/Gelbe Liste
IMPROVED: master data management interface
IMPROVED: fix "Current Substance Intake" edit area usability glitches (schedule, substance, preparation)
IMPROVED: much saner "deletion of substance intake entry" workflow
IMPROVED: logically cleaner substance intake handling
IMPROVED: find gm-print_doc in git tree, too
IMPROVED: relax URL sanity checks since Web 2.0 confuses all but the most sophisticated browsers
IMPROVED: default server profile names in gnumed.conf example
IMPROVED: alpha-sort list of master data lists as per mailing list
IMPROVED: external patient sources now generically import external IDs/comm channels/addresses
IMPROVED: fix detection of existing patient when loading from external source
IMPROVED: workplace plugin configuration using item picker
IMPROVED: in phrasewheel support dynamic part of tooltip based on selected item data
IMPROVED: location PRW in procedure EA: re-use hospitals from hospital stays
IMPROVED: support arriba 2.2.2 and its new file-based API
IMPROVED: substance intake grid: display unapproved by default
IMPROVED: default temporary directory now /tmp/gnumed/gm-/ per GNUmed instance
IMPROVED: menu structure creation such that accelerator keys work more reliably
IMPROVED: EMR tree can now display selective chronological journal on issues and episodes
IMPROVED: existing translations
IMPROVED: make showing audit trail a restricted procedure
IMPROVED: enable exporting of in-database form template
IMPROVED: show RFE/AOE in "recent notes" display in SOAP plugin
IMPROVED: much saner workflow when creating allergy entry from substance intake
IMPROVED: configurably auto-open editors for all open, recently worked-on problems when activating a patient
IMPROVED: SOAP plugin: [Save under] saves notelet under selectable rather than current encounter
IMPROVED: enable moving documents between encounters, mainly useful for visual progress notes
IMPROVED: do not at all use wx.DatePickerCtrl as it breaks on some locales (en_IN) [thanks vbanait]
IMPROVED: management of configuration items


Please download, install, and report problems !

Thanks,
Karsten

2 comments:

Tonatiuh said...

Enhorabuena!!!

I'm an fisioterapian student in the University Alfonso X el sabio, in Madrid, and I'm very interested in GNUmed.

Do you know when it is going to be in de PPA for Ubuntu? I'm trying to install it but I have no luck with the 0,8 client and v14 of the server. I do something wrong when trying to configure the postgreql.

It is something wrong with the 64 bit editiĆ³n?

I need it to be working as soon as possible because I was going to present it in my university to the class.

So if you can help me I'll be very happy.
Thank you, Tonatiuh

Sebastian Hilbert said...

Hi,

We need to know what your problem is in order to help you. GNUmed 0.9.1 is in the PPA.

What fails ? The client ? The server ?

Contact us at gnumed-devel@gnu.org for the fastest way to help you out.

Have a look at UbuntuGuideShort