Saturday, March 23, 2013

GNUmed 1.3.1 released

Hello all,

I am glad to be able to announce the immediate availability
of the GNUmed 1.3.1 Maintenance Release. It features the
following bug fixes and minor improvements:



 FIX: make gmHL7 import optional [thanks J.Luszawski/A.Tille]
 FIX: exception on showing timeline [thanks S.Hilbert]
 FIX: exception on searching across EMRs [thanks V.Banait]
 FIX: exception on formatting external IDs in overview [thanks S.Hilbert]
 FiX: exception on merging patients with same comm channel [thanks M.Angermann]

 IMPROVED: have prerequisite check look for python-hl7 [thanks J.Luszawski]
 IMPROVED: patient overview waiting list hint tooltip [thanks J.Busser]


 FIX: gm-doctors must be member of gm-public
 FIX: exception dumping schema revision history of early DB versions [thanks Š.Laczi]

 IMPROVED: bootstrapper now checks gm.schema_revision AND public.gm_schema_revision

Downloads available from:

Client installation:

 Easily installable packages for your platform of choice
 will be available shortly.

 Meanwhile you can run the client from a downloaded tarball
 or use the net based client installer:

 which you need to download, make executable, and run.

 More information available here:

Database installation / upgrade:

 Note that this release, as usual, does NOT require a
 database upgrade. However, fixes to the database
 have been provided which you should install
 with either

        $> gm-fixup_server 18


        $> cd .../server/bootstrap/
        $> ./ 18

 Related information is found here:

Please download, install, and report problems !


No comments: